Rapture3D Universal SDK Technical Requirements

Please check that everything is okay here before purchasing software.

Software Development Kit - Operating System

Supported versions of Microsoft Windows are XP, Vista, Windows 7, Windows 8 and Windows 10. Supported versions of Apple macOS are 10.5 or later, Intel only.

Software Development Tools - C/C++

A variety of tools can be used. Supported tools are Microsoft Visual Studio 2010 on Windows and Xcode 7 on macOS.

Software Development Tools - Unity

Unity version 5 is supported. Please note that Rapture3D Universal uses native plugins which are not supported by all versions of Unity.

Software Development Kit - PC Hardware

Please check your PC meets the following requirements:

  • Intel Pentium D CPU or better.
  • 1GB of free disk space.
  • Internal network card.

Internet Connection Required

The SDK requires an Internet Connection for license activation and verification. We don't really like this, but we can't think of a better way to discourage piracy! Please don't hack our code, it's taken a lot of effort to get it this far...

Successful license verification isn't required every time you use the software, but it is needed during installation and needs to succeed once every couple of weeks to keep the license fresh.

The license can be "revoked" to remove it from one machine so it can be moved on to another. You should also do this if you're updating your system in case the machine appears to have changed identity.

Permissions

You'll need administrator permissions while installing. The software won't install properly using a "restricted" account.

Redistributables

Capabilities and performance will obviously depend on the hardware you deploy to, what other software is in use, Rapture3D settings, how much work you ask Rapture3D to do, and other factors. Please test before deploying! Rapture3D has quality settings that allow scaling onto a wide range of platforms:

  • Apple macOS 10.5 to 10.11, Intel 32bit/64bit Universal Binary.
  • Windows XP, Win7, Win8, Win10, Intel 32bit/64bit.
  • Android R9 and later, armeabi-v7a or x86.
  • iOS 8 and later.